Slave Prerequisites Plugin

Slave prerequisites